1. #1
    Avatar de ndyop Petit nouveau
    Inscrit
    mai 2019
    Messages
    6

    Crash au lancement de Unity

    Bonjour,

    Peut-être qu'un de vous à la solution, le support Ubisoft faisant le mort...(ticket 08778735)

    J'ai installé Unity depuis Uplay il y a 10 jours sur mon PC Win 10 avec une GeForce RTX 2070.
    Le jeu se lance et dès la première seconde de video du logo Ubisoft, le jeu crash sans message d'erreur.

    J'ai envoyé un rapport détaillé au support d'Ubisoft avec l'erreur dans l'event windows, le DXDiag, le MSinfo et tout ce que j'ai déjà essayé.

    Ce que j'ai déjà fait :

    J'ai les derniers drivers Nvidia 430.39
    Windows 10 est à jour et j'ai déjà redémarré.
    Les drivers du PC et le bios sont à jour.
    J'ai bien installé le.net 3.5 (demandé à l'install du jeu).
    J'ai désactivé les services non nécessaires au système, désactivé l'antivirus.
    J'ai tenté la vérification des fichiers du jeu dans Uplay, tout est ok.
    J'ai tenté de modifier le ACU.ini pour mettre une résolution de 1920*1080 (mon écran est en 1440p de base).
    J'ai modifié la résolution de mon écran pour passer en 1920x1080
    J'ai testé le renommage de tous les fichiers Xaudio27.dll (certains forums parlent d'un prob avec ce fichier).
    J'ai vérifié que le FXAA est désactivé dans les drivers Nvidia.
    J'ai désactivé l'overlay dans Uplay et dans Geforce Experience et je n'ai pas d'autres programmes avec un overlay.
    J'ai exécuté le jeu en admin.
    J'ai réinstallé le jeu via Uplay à différents endroits.
    J'ai modifié la résolution et d'autres paramètres dans le ACU.ini (dans documents)
    J'ai créé un fichier gfxsettings.acu.xml en recopiant et adaptant des lignes trouvées dans ce forum. Car le fichier est absent dans le dossier documents\assasins creed unity

    Une autre idée ?
    Share this post

  2. #2
    Avatar de Ubi-Caliburn Ubisoft Support Staff
    Inscrit
    octobre 2018
    Messages
    1 237
    Bonjour ndyop,

    Navrée d'apprendre que tu rencontres des crashs dans Assassin's Creed Unity sans message d'erreur. Je te remercie pour les détails que tu nous as partagé à propos des étapes que tu as déjà suivies.

    Le dossier GFXSettings.ACU.xml n'est absent du dossier Mes Documents\ Assassin's Creed Unity que dans le cas où le jeu ne possède pas les droits d'administrateur et/ou n'est pas installé sur le même disque dur que le système d'exploitation.
    Je te conseille donc de vérifier qu'Assassin's Creed Unity est bien installé sur le disque dur C (ou celui sur lequel est installé Windows) et que ce dernier dispose des droits d'administrateur.

    Une fois ceci effectué tu devrais être en mesure de trouver le fichier "GFXSettings.ACU.xml".
    Dans ce dernier je te conseille de chercher la ligne suivante :

    <RESOLUTION Width="XXXX" Height="XXXX" RefreshRate="XX">

    Les XXXX correspondant à la valeur générée par le jeu lors de son auto-détection

    Je t'invite donc a modifier cette dernière suivant tes préférences d'affichage, prends note du fait que ton fichier Dxdiag indique la résolution native suivante :

    <RESOLUTION Width="2560" Height="1440" RefreshRate="120">

    Une fois modifié sauvegarde et relance ton jeu.

    Tiens-nous au courant des résultats que tu obtiens !
    Share this post

  3. #3
    Avatar de ndyop Petit nouveau
    Inscrit
    mai 2019
    Messages
    6
    Bonjour,

    Merci pour la réponse.

    Le jeu est installé sur le disque système c: à l'emplacement par défaut.
    Le compte windows est admin local du pc. J'ai tout de même tenté de lancer uplay "en tant qu'administrateur".

    Le fichier GFXsettings ne se créé pas automatiquement, daprès ce que j'ai lu, il se créé si on arrive à lancer le jeu une fois, mais comme je n'y parviens pas je n'en ai pas.

    J'ai tout de même modifier le ACU.ini pour y changer le framerate de 60 à 120 hz (60 est la valeur par défaut dans le fichier.

    J'ai trouvé un fichier GFXSettingsACU sur un forum, je l'ai modifié pour y mettre ça :

    <?xml version="1.0" encoding="UTF-16" standalone="no"?>
    <GSA_SDK Version="2.3.18713301.0">
    <APPLICATION>
    <DISPLAYNAME Value="Assassin's Creed Unity" />
    <VERSIONNAME Value="1.0" />
    <INSTALLPATH Value="C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\games\Assassin's Creed Unity" />
    <CONFIGPATH Value="C:\Users\ndyop\OneDrive\Documents\Assassin' s Creed Unity />
    <EXECUTABLE Value="ACU" />
    <EXECCMD Value="" />
    </APPLICATION>
    <GAMESETTINGS>
    <RESOLUTION Width="2560" Height="1440" RefreshRate="120">
    <ENUM Width="640" Height="480" RefreshRate="60" />
    <ENUM Width="640" Height="480" RefreshRate="75" />
    <ENUM Width="720" Height="480" RefreshRate="56" />
    <ENUM Width="720" Height="480" RefreshRate="60" />
    <ENUM Width="720" Height="480" RefreshRate="75" />
    <ENUM Width="720" Height="576" RefreshRate="56" />
    <ENUM Width="720" Height="576" RefreshRate="60" />
    <ENUM Width="720" Height="576" RefreshRate="75" />
    <ENUM Width="800" Height="600" RefreshRate="56" />
    <ENUM Width="800" Height="600" RefreshRate="60" />
    <ENUM Width="800" Height="600" RefreshRate="75" />
    <ENUM Width="1024" Height="768" RefreshRate="60" />
    <ENUM Width="1024" Height="768" RefreshRate="75" />
    <ENUM Width="1152" Height="864" RefreshRate="75" />
    <ENUM Width="1280" Height="720" RefreshRate="60" />
    <ENUM Width="1280" Height="768" RefreshRate="60" />
    <ENUM Width="1280" Height="800" RefreshRate="60" />
    <ENUM Width="1280" Height="960" RefreshRate="60" />
    <ENUM Width="1280" Height="1024" RefreshRate="60" />
    <ENUM Width="1280" Height="1024" RefreshRate="75" />
    <ENUM Width="1360" Height="768" RefreshRate="60" />
    <ENUM Width="1366" Height="768" RefreshRate="60" />
    <ENUM Width="1600" Height="900" RefreshRate="60" />
    <ENUM Width="1600" Height="1024" RefreshRate="60" />
    <ENUM Width="1680" Height="1050" RefreshRate="60" />
    <ENUM Width="1920" Height="1080" RefreshRate="60" />
    <ENUM Width="2715" Height="1527" RefreshRate="60" />
    <ENUM Width="2880" Height="1620" RefreshRate="60" />
    <ENUM Width="3325" Height="1871" RefreshRate="60" />
    <ENUM Width="3840" Height="2160" RefreshRate="60" />
    </RESOLUTION>
    <OPTION Name="VSYNC" Registered="True" Type="Bool" Value="false" />
    <OPTION Name="AA" Registered="True" Type="Integer" Value="1">
    <RANGE MinValue="0" MaxValue="6" NumSteps="0" />
    </OPTION>
    <OPTION Name="ENVIRONMENT" Registered="True" Type="Integer" Value="3">
    <RANGE MinValue="0" MaxValue="4" NumSteps="0" />
    </OPTION>
    <OPTION Name="TEXTURES" Registered="True" Type="Integer" Value="2">
    <RANGE MinValue="0" MaxValue="2" NumSteps="0" />
    </OPTION>
    <OPTION Name="SHADOWS" Registered="True" Type="Integer" Value="1">
    <RANGE MinValue="0" MaxValue="2" NumSteps="0" />
    </OPTION>
    <OPTION Name="SSAO" Registered="True" Type="Integer" Value="2">
    <RANGE MinValue="0" MaxValue="2" NumSteps="0" />
    </OPTION>
    <OPTION Name="POST_FX" Registered="True" Type="Bool" Value="true" />
    <OPTION Name="REFLECTIONS" Registered="True" Type="Integer" Value="2">
    <RANGE MinValue="0" MaxValue="3" NumSteps="0" />
    </OPTION>
    </GAMESETTINGS>
    </GSA_SDK>

    Mais même avec ce fichier présent le jeu plante au lancement après 1 seconde.
    Share this post

  4. #4
    Avatar de Ubi-Caliburn Ubisoft Support Staff
    Inscrit
    octobre 2018
    Messages
    1 237
    Merci pour ton retour ndyop,

    Après une vérification plus approfondie des fichiers systèmes que tu as ajouté à ton dossier je t'invite à installer le logiciel suivant nécessaire à l'utilisation du Game Mode de ton CPU.
    Cela devrait aider concernant le lancement du jeu.
    Une fois ce mode activé pourras-tu résessayer les étapes précédentes ?

    Dans un second temps j'ai pu remarque que dans le fichier GFXsettings que tu as créé la ligne <CONFIGPATH Value="C:\Users\ndyop\OneDrive\Documents\Assassin' s Creed Unity /> indique que le dossier en question est sur OneDrive, pourrais-tu véirifier que le dossier Documents\Assassin' s Creed Unity n'est pas sur One Drive ?

    Tiens-moi au courant des résultats que tu obtiens.
    Share this post

  5. #5
    Avatar de ndyop Petit nouveau
    Inscrit
    mai 2019
    Messages
    6
    Bonjour,

    Le logiciel Ryzen master est déjà installé sur mon pc et sert à la surveillance de mon CPU, il n'a aucune incidence sur le fonctionnement des jeux, hormis en améliorer les performances en "gaming mode". Quoi qu'il en soit, même en gaming mode le problème est le même.

    Concernant l'emplacement du fichier que j'ai créé, je l'ai créé au même endroit que le fichier ACU.ini à l'emplacement par défaut au moment de l'installation du jeu.
    Cet emplacement est bien C:\Users\ndyop\OneDrive\Documents\Assassin' s Creed Unity
    Si j'efface le fichier ACU.ini il est recréer automatiquement par le jeu, le problème n'est donc pas un problème d'accès à ce répertoire.
    Share this post

  6. #6
    Avatar de ndyop Petit nouveau
    Inscrit
    mai 2019
    Messages
    6
    J'ajoute que je viens de tester de renommer le dossier C:\Users\ndyop\OneDrive\Documents\Assassin' s Creed Unity et le jeu en recréé un automatiquement dès que je lance le jeu avec un fichier ACU.ini dedans.
    Share this post

  7. #7
    Avatar de Ubi-Caliburn Ubisoft Support Staff
    Inscrit
    octobre 2018
    Messages
    1 237
    Le "gaming mode" permet normalement de désactiver un certain nombre de coeurs en jeu, en effet le CPU que tu utilises à un nombre de coeur qui peut être trop important pour permettre à Assassin's Creed Unity d'être lancé correctement considérant que ce dernier a été créé pour des processeurs de 2 à 4 coeurs.

    Dans un second temps le fait que le dossier en question soit sur OneDrive peut causer un problème à trouver le fichier puisqu'il ne s'agit pas du fichier originel mais d'une synchronisation de ce dernier.
    Peux-tu déplacer ce dernier dans les documents présents sur ton ordinateur ? Ou trouver le chemin de l'emplacement originel dans tes documents ?
    Share this post

  8. #8
    Avatar de ndyop Petit nouveau
    Inscrit
    mai 2019
    Messages
    6
    Bonjour,

    J'ai testé en gaming mode et cela ne fonctionne pas mieux.
    Windows 10 synchronise de base sur Onedrive les documents du profil, j'ai testé en mettant les fichiers ACU et GFX (que j'ai créé) sur les documents de mon profil mais ça ne change rien, le jeu n'en tient pas compte et garde l'emplacement par defaut sur OneDrive.

    J'essaierais de désactiver complètement OneDrive et de réinstaller le jeu ce soir mais je doute que ce soit ça le problème vu que le jeu arrive très bien à recréer le fichier s'il n'y est pas.
    Share this post

  9. #9
    Avatar de ndyop Petit nouveau
    Inscrit
    mai 2019
    Messages
    6
    Bonjour,

    J'ai réessayer en repartant de zero en gaming mode et ça fonctionne. Le jeu est ainsi sur 8 cores 16 threads

    Dès que je repasse en creator mode ou custom le jeu ne se lance plus. J'ai laissé la synchro OneDrive.

    Une fois le jeu lancé le fichier GFXSettingsACU se créé correctement avec les bons paramètres.

    Pour d'autres qui auront le problème je confirme que pour l'instant avec un Threadripper 2990WX il faut utiliser le gaming mode. Je n'ai pas le problème avec d'autres anciens jeux, il y a quelque chose dans ACU qui ne foncitonne pas avec les CPU à beaucoup de coeurs.


    Merci à Ubi-Caliburn pour l'aide.
    Share this post

  10. #10
    Avatar de Ubi-Frons Ubisoft Support Staff
    Inscrit
    décembre 2018
    Messages
    1 089
    Bonjour ndyop,

    Je suis désolé que nous ne t'ayons pas répondu plus tôt.

    Je suis heureux d'apprendre que ton problème a été résolu et je partage ta solution aux équipes si jamais nous rencontrons ce problème de nouveau.

    Encore merci et passe une très bonne journée.
    Share this post