1. #1
    Avatar de Agent_Marcel Forumeur fou
    Inscrit
    décembre 2006
    Messages
    2 156

    Problèmes réseau : Nouvellepiste, l'Automatic Load Balancing

    (Goib, je poste ces messages parce que je sais très bien qu'ils sont remontés par Apo aux Devs, même si je ne lui ai jamais demandé).

    L'Automatic Load Balancing, ou équilibrage automatique de la charge d'un processeur, est plutôt un truc utilisé dans les configurations multi-processeurs "tighty coupled" de type cluster, dans lesquelles un CPU est soulagé par l'attribution automatique et transparente d'une nouvelle tâche à son voisin.
    Dans le cas qui nous occupe, ce serait plutôt de l'Automatic Load Management, soluce qui consiste à déconnecter un process qui ne "fait rien".
    En effet, hier j'ai fini ma première map de chasse aux terros en mode réaliste (si, si) et j'ai bien évidemment souhaité immortaliser cet instant : Hereford en 4'30
    Jouant sur PS4 (on le savait), j'ai donc pressé la touche SHARE, j'ai uploadé mon clip, et suis revenu dans mon jeu.
    Oh surprise !

    "Erreur réseau n° blablabla vous avez été déconnecté, patin couffin"

    Deux cas de figure peuvent alors se présenter, à mon avis :

    1° quand on "suspend" (il y a message) le jeu pour gérer ses clips, le message d'erreur est erroné. Il devrait dire "la suspension de votre session de jeu a été trop longue et vous avez été timeouté", ce que l'on peut comprendre.

    2° il y a un daemon quelque part dans le netcode qui traque les I/O et quand ils tombent, boum, on est déconnecté.

    Qu'en pensent les connaisseurs ?

    Moi, j'aime bien l'hypothèse 2...

    Merci.

    A++
    Share this post

  2. #2
    Avatar de apdji Forumeur permanent
    Inscrit
    juin 2015
    Lieu
    Toulouse
    Messages
    2 612
    Perso je vois surtout un multi thread qui pète
    Share this post