PDA

Afficher la version complète : Ultrapack2.01 updater / switcher / JSGME ... et update 4.10



Candiousky
27/02/2011, 07h33
Bonjour à tous,

Je suis finalement parvenu a installer l'Ultrapack 2.01, à priori avec succès. Maintenant,je cherche à savoir à quoi servent les programmes Ultrapack updater, Utrapack switcher et JSGME mais également, quand y a-t-il lieu de les utiliser? Par ailleurs, j'aimerais comprendre le lien qu'il y a ou qu'il peut y avoir entre l'Ultrapack et la version 4.10 d'IL2...

Pour l'instant, la compréhension que j'ai de l'Ultrapack est qu'il s'agit d'un programme permettant d'implémenter (ou pas) différents mods dans une version 4.09 de base et éventuellement de switcher de cette version 4.09 à la version 4.10 et vice versa. Cependant, certains mods sont implémentés par défaut par rapport à la version 4.09 de base. Ainsi, des avions de l'IA non pilotables en 4.09 le deviennent par défaut avec l'Ultrapack...

Question subsidiaire: la version 4.09/Ultrapack 2.01 est-elle compatible en ligne avec une version 4.09 de base?

Je suis conscient que je pose beaucoup de questions mais j'aime comprendre ce que je fais!

Merci d'avance.

Cordialement,

Candiousky

Candiousky
27/02/2011, 07h33
Bonjour à tous,

Je suis finalement parvenu a installer l'Ultrapack 2.01, à priori avec succès. Maintenant,je cherche à savoir à quoi servent les programmes Ultrapack updater, Utrapack switcher et JSGME mais également, quand y a-t-il lieu de les utiliser? Par ailleurs, j'aimerais comprendre le lien qu'il y a ou qu'il peut y avoir entre l'Ultrapack et la version 4.10 d'IL2...

Pour l'instant, la compréhension que j'ai de l'Ultrapack est qu'il s'agit d'un programme permettant d'implémenter (ou pas) différents mods dans une version 4.09 de base et éventuellement de switcher de cette version 4.09 à la version 4.10 et vice versa. Cependant, certains mods sont implémentés par défaut par rapport à la version 4.09 de base. Ainsi, des avions de l'IA non pilotables en 4.09 le deviennent par défaut avec l'Ultrapack...

Question subsidiaire: la version 4.09/Ultrapack 2.01 est-elle compatible en ligne avec une version 4.09 de base?

Je suis conscient que je pose beaucoup de questions mais j'aime comprendre ce que je fais!

Merci d'avance.

Cordialement,

Candiousky

GCIII-6_Hartenstein
27/02/2011, 14h02
Alors...

L'ultrapack Updater est un programme qui permet de mettre à jour ton installation UP sans devoir aller chercher toi-même sur le net l'installateur.

L'UP Switcher te permet de passer d'une installation 2.01 à une installation 2.0 (perso, je n'en vois pas l'intérêt, mais certains préfèrent les anciennes versions)

Le JSGME est un programme très très important. Une fois installé, l'UP n'a activé qu'un certain nombre de mods qu'il a installé, mais pas d'autres, qui relèvent des mods optionnels dont l'activation dépend plus des préférences de l'utilisateur que d'un cas général. On y trouve également des mods spécifiques à n'activer que sur certains serveurs.
Parmi les mods qu'on peut y activer, on y trouve, par exemple, un mod optimisant Il2 pour une certaine quantité de mémoire vive, un mod activant les croix gammées sur les appareils allemands et finlandais, un mod incorporant une météo plus réaliste, un mod permettant d'activer le 6DoF pour le Track IR...
Ce programme peut permettre également de réactiver les installations sans mods du jeu, sans devoir pour autant tout désinstaller ("4.09m stock" et "4.101m Stock").

Pour ta question subsidiaire, oui, l'UP2.01 peut être compatible avec une installation 4.09m online, à une condition:
Le fichier conf.ini dans le répertoire du jeu contient une ligne qui active une option empêchant une installation moddée d'interagir avec une installation non moddée. Si cette ligne n'est pas activée, il n'y a pas de souci. Il s'agit de la ligne "CRT=0" (si CRT=0, il est possible de faire interagir les deux installations. Si, par contre, c'est CRT=2, les deux jeux refuseront de communiquer).


Espérant avoir réussi à répondre à tes questions...

Candiousky
28/02/2011, 13h54
Salut Harty,

Merci pour tes réponses. Dans la dernière phrase de ton 3ème paragraphe, c'est bien à la version 4.10 ("4.101m Stock")que tu fais référence? Si c'est le cas, j'en conclus que l'UP 2.01 englobe l'update 4.10 et que par conséquent, à part l'activer par l'intermédiaire du JSGME, il n'y a rien de plus à faire l'on veut utiliser cette version...
C'est bien cela?

GCIII-6_Hartenstein
01/03/2011, 11h58
Effectivement, il suffit d'activer "4.10m Stock" pour activer la version 4.10m. Mais cette version n'est pas encore compatible avec les mods, donc, si tu l'actives, cela lancera une version originale du jeu (bien entendu, sa désactivation fait retourner le jeu en 4.09m moddé UP2.01).

C'est aussi pour cette raison d'incompatibilité avec les mods que l'installation par défaut reste en 4.09m.

L'installation de l'UP 2.01 intègre de base la version 4.10m ("4.10m Stock"), sans qu'il y ait nécessité de recourir au téléchargement du patch officiel.
Il te faudra cependant installer le correctif pour l'UP téléchargeable à cette adresse sur le forum Ultrapack (http://ultrapack.il2war.com/index.php/topic,3426.0.html) pour installer la version officielle débuggée 4.101m ("4.101m stock").

rafalespirale
02/03/2011, 08h15
Bonjour tout le monde. http://webtools.fr.ubi.com/forums/smileys/happy.gif
Je me permets d'utiliser le sujet, http://webtools.fr.ubi.com/forums/smileys/panneau005.png si ça a déjà été traité ailleurs...
Sur le site de l'Ultrapack ils disent qu'ils faut avoir installé UP 2.0n avant d'installer UP 2.01. Moi je veux bien, mais jusqu'ici j'ai pas réussi à trouver un endroit où télécharger ce fameux UP 2.0n (donc UP 2.0 je suppose).
Alors faut-il vraiment UP 2.0 ou alors je n'ai rien compris au film ? http://webtools.fr.ubi.com/forums/smileys/panneau004.png Et s'il le faut, où peut-on trouver ce damné pack ? Vous pouvez tout à fait m'emmener sur un post du forum pour me rediriger... Merci par avance...

GCIII-6_Hartenstein
02/03/2011, 13h36
Il n'est pas nécessaire d'installer la version 2.0n avant d'installer une version UP2.01.

Tu peux aller chercher la version complète à cette adresse du forum Ultrapack (http://ultrapack.il2war.com/index.php/topic,2088.0.html) .

Dans la première intervention, celle de HaDeS, tu descend un peu, et en dessous du patch 2.01 pour une installation 2.0n, tu trouveras "UP 2.01 Full Download", qui te permettra de télécharger les 9 (!) parties de la version complète.

rafalespirale
02/03/2011, 16h15
J'en suis à la partie 7. Ca n'était pas clair leur modus operandi sur le site de l'ultrapack, mais ça devrait bien se passer l'installation... En tout cas merci, parce que j'avais un gros doute.

raffiot357
03/03/2011, 06h22
Bonjour;
Tout d'abord un grand merci à tous ceux qui expliquent patiemment jour après jour les subtilités des patches, des mods, des ultrapcks, des mises à jour, etc...
Grâce à tous ces conseils je pense avoir actualisé mon jeu mais je souhaiterais néanmoins avoir l'avis de spécialistes.
Au lancement du jeu apparait : "V 4.09 m / Il2 2.46 modified Ultrapack 2.01".
Puis je encore améliorer cette configuration ?
Comme "ça vole" déjà je ne touche à rien pour ne pas tout planter http://webtools.fr.ubi.com/forums/smileys/sweatingbullets.gif
D'avance merci pour vos conseils. http://webtools.fr.ubi.com/forums/smileys/panneau011.png
Raffiot

Candiousky
03/03/2011, 09h22
Salut,

Merci Harty pour les infos complémentaires! Pour moi tout est clair maintenant. Enfin, faudra voir à l'usage!

Bons vols à tous.

Candiousky

rafalespirale
03/03/2011, 10h59
Bon, donc je récapitule pour l'installation d'UP 2.01 :
- j'ai une install HSFX et pas de sauvegarde de ma 4.09m clean ou de ma 4.10m clean (oui je sais c'est pas bien http://webtools.fr.ubi.com/forums/smileys/sweatingbullets.gif), comment ça va se passer de ce côté-là (j'avais installé direct HSFX sur la 4.10m, donc plus de 4.10m clean mais 4.09m stock lorsque mods désactivés) ?
- j'ai toutes les parties (installeur partie 1 plus les .cab jusqu'à 9)
- je prévois 10.2 "Gigbytes" (prononcer "Djigbaytss" http://webtools.fr.ubi.com/forums/smileys/vomir.png) sur mon ami le DD (le petit nom que j'ai donné aux Go NDLR, non, pas les gentils organisateurs, mais ça pourrait vu leur importance http://webtools.fr.ubi.com/forums/smileys/rire.png, en français "Gigocts", pas d'agneau http://webtools.fr.ubi.com/forums/smileys/langue.gif)
- je lance l'installateur, qui me fait tout le reste (sympa l'installateur http://webtools.fr.ubi.com/forums/smileys/love.gif)
Ca va marcher ? Et comment ça va marcher ? http://webtools.fr.ubi.com/forums/smileys/fear.gif

GCIII-6_Hartenstein
03/03/2011, 14h38
<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Message original par raffiot357:
Au lancement du jeu apparait : "V 4.09 m / Il2 2.46 modified Ultrapack 2.01".
Puis je encore améliorer cette configuration ?
Comme "ça vole" déjà je ne touche à rien pour ne pas tout planter http://webtools.fr.ubi.com/forums/smileys/sweatingbullets.gif
D'avance merci pour vos conseils. http://webtools.fr.ubi.com/forums/smileys/panneau011.png
Raffiot </div></BLOCKQUOTE>

Ne touche plus à rien niveau programme d'installation, tu as tout ce qu'il faut pour une installation Ultrapack à jour. Si tu veux activer/désactiver certaines choses, utilise désormais le programme JSGME, qui fera ça proprement et sans risque d'installer ou désinstaller quoi que ce soit.
Au pire, si tu souhaites essayer une installation non-moddée 4.101m, utilise le patch à l'ultrapack dispo sur leur forum.

<BLOCKQUOTE class="ip-ubbcode-quote"><div class="ip-ubbcode-quote-title">quote:</div><div class="ip-ubbcode-quote-content">Message original par RafSpi:
- j'ai une install HSFX et pas de sauvegarde de ma 4.09m clean ou de ma 4.10m clean (oui je sais c'est pas bien *LoL*), comment ça va se passer de ce côté-là (j'avais installé direct HSFX sur la 4.10m, donc plus de 4.10m clean mais 4.09m stock lorsque mods désactivés) ?
- j'ai toutes les parties (installeur partie 1 plus les .cab jusqu'à 9)
- je prévois 10.2 "Gigbytes" (prononcer "Djigbaytss" http://webtools.fr.ubi.com/forums/smileys/vomir.png) sur mon ami le DD (le petit nom que j'ai donné aux Go NDLR, non, pas les gentils organisateurs, mais ça pourrait vu leur importance http://webtools.fr.ubi.com/forums/smileys/rire.png, en français "Gigocts", pas d'agneau http://webtools.fr.ubi.com/forums/smileys/langue.gif)
- je lance l'installateur, qui me fait tout le reste (sympa l'installateur *Love*)
Ca va marcher ? Et comment ça va marcher ? *Peur*

</div></BLOCKQUOTE>

L'ultrapack doit normalement s'installer sur une installation clean (sans mod) d'Il2 1946 patché en 4.09m. Si tu as le HSFX d'installé, essayes de le dégager ou de tout désinstaller et de réinstaller au propre (note: le HSFX se trouve également dans l'UP, il est d'ailleurs activable par le programme UP Switcher dont je viens, du coup, de me souvenir de sa réelle fonction). Si tu n'y arrives pas, fais une copie de sauvegarde de ton répertoire d'Il2 et tente tout de même une installation de l'UP sur ton installation HSFX... Succès non garantie dans ce cas précis...

Pour que l'UP s'installe correctement, toutes les parties du pack doivent se trouver dans le même répertoire. Ensuite, tu as juste à lancer la partie 1 pour qu'il installe les 9 (l'installation peut être un peu longue... C'est qu'il n'est pas léger, ce pack!). C'est tout!

rafalespirale
03/03/2011, 16h15
OK, c'était bien comme ça que je l'entendais mais je souhaitais confirmation, parce que c'est un joli mélo tout ce fourbi.
Je pense que je vais juste installer l'UP, parce que j'avais essayé de distinguer les éléments de la 4.10m clean de ceux de l'HSFX, et il semble que j'ai pas réussi.
Advienne que pourra, mais je pense à sauvegarder les éléments non-originels comme les skins, pour éviter de les perdre.

raffiot357
03/03/2011, 23h49
Merci à Hartenstein pour ces précisions.
Je ne touche plus à rien.
Bon week end http://webtools.fr.ubi.com/forums/smileys/panneau011.pngà tous.
Cordialement.
Raffiot

raffiot357
03/10/2011, 11h43
Bonsoir à tous;
Engagé dans la réinstallation de IL2 1946 j'ai cru comprendre sur le site "http://ultrapack.il2war.com" que la version "Ultrapack 2.01" n'était plus téléchargeable http://webtools.fr.ubi.com/forums/smileys/pascontent.png (les liens s'ouvrent sur une page blanche) et était remplacée par la "UP 3.0 RC Download".
Merci aux personnes qui pourront apporter quelques éléments de réponse à mes questions :
1/ Faut il installer UP 3.0 et ensuite installer les 9 fichiers que l'ont installait avec UP 2.01 ?
Le problème est que les liens de ces 9 fichiers s'ouvrent aussi sur une page blanche...
2/ Comment accéder à ce jour à l'installation référencée : "V 4.09m / Il2 2.46 modified Ultrapack 2.01".
D'avance merci. http://webtools.fr.ubi.com/forums/smileys/panneau011.png
Je continue à éplucher les forums en anglais au cas où ... http://webtools.fr.ubi.com/forums/smileys/sweatingbullets.gif
Bonne soirée et bons vols http://webtools.fr.ubi.com/forums/smileys/yes.png.
Raffiot.

GCIII-6_Hartenstein
05/10/2011, 03h20
L'UP 2.01 n'est effectivement plus téléchargeable sur le site officiel de l'UP, car ils sont effectivement passés à la version UP3.0 RC4. La plupart des serveurs online sont passés aussi à cette version et l'UP2.01 est passé aux oubliettes. Tu trouveras peut-être encore les fichiers de l'UP 2.01 sur des sites de nostalgiques de cette version, mais je pense que auras du mal à les retrouver...

La meilleure solution pour toi, je pense, est de passer tout de suite à la version UP3.0RC4.

Pour cela, il te faut une installation "clean" d'Il2 que tu vas patcher avec les patchs officiels 4.08, 4.09, 4.10 et 4.101 (je sais qu'il existe un mégapatch créé par un membre de la communauté permettant de passer direct à la version 4.101 depuis une version 4.07, mais je ne saurai pas te dire où le télécharger).

Ensuite, tu télécharges les fichiers composant l'UP3.0RC4 et tu l'installes (même type d'installation que pour l'UP 2.01).

Quand tu activeras l'UP3.0 et que tu lanceras Il2, tu auras une fenêtre d'option qui s'affichera te permettant de personnaliser certaines options de mémoire (par exemple) ou l'activation du 6DoF (si tu as un Track IR). Ne pas trop bricoler dedans si tu n'es pas un expert, certaines options peuvent faire planter le jeu. Clique ensuite sur "Launch Il-2" et le jeu démarre.

raffiot357
06/10/2011, 11h16
Bonsoir et http://webtools.fr.ubi.com/forums/smileys/panneau011.png pour ces précisions.
Je m'en occupe ce week end.
A défaut d'exploiter à 100% COD, puisque mon ordi est trop faible, je vais alors exploiter IL2 !
Bons vols !
Raffiot